Catalog API limit

Why is when I set the limit in Catalog API to 100 I get status code 200 but when I set it to 500 I get status code: 400 ?

The parameter limit (number of responses in result) has a maximum value of 100.
You should use pagination if you need more results:

If I use the next argument I can only see the results of that page, e.g., if next=5 , then I see the results of page 5, but it is not all the results.
Does it mean that I need to run the API request several times changing the value in the next argument (i.e., the page number) each time?

Yes indeed, you can use limit=100 and then repeat the request a few times, regarding how many results you have.
I recommend to check the “distinct” parameter as well, as it might allow you to reduce number of results by focusing to parts you are interested in

Can you explain what does it mean :

Using distinct it is possible to get some overview of the data available inside the specified query. For example specifying date as an option will return a list of dates where data is available.

Why would I want dates when data is not available?

distinct sounds like it should only return one date when multiple images exist on the same date, instead of having multiple results with the same date (but different image_id)

You understand the functionality well.

I don’t know your use-case. Many of our clients use this function to get list of available dates over specific AOI, as they are not interested in multiple images for same day.