Sentinel-2 missing images


#1

Hi,

I’m using this query to get an image from a location. I use a TIME option (2017-09-30) to get the most recent from my parameters and use the DATE option for LAYERS and the result is an image from 2017-08-29. Is this normal ? For me, for a location, in general, you will have 1 image per week. When I go back backward in time I can similar date gap.

Query :

http://services.sentinel-hub.com/ogc/wms/{TOKEN}?REQUEST=GetMap&LAYERS=TRUE_COLOR,DATE&FORMAT=image/png&WIDTH=500&HEIGHT=500&GEOMETRY=POLYGON((-102.6799780643014230%2032.2664152159741064,-102.6798633201786117%2032.2709222209287176,-102.6745585116752011%2032.2708246109079226,-102.6746735175748455%2032.2663176228672697,-102.6799780643014230%2032.2664152159741064))&CRS=CRS:84&MAXCC=0.0&TIME=2017-09-30

Thanks for your time,

Jocelyn


#2

Hi Jocelyn,

check what kind of “maximum cloud coverage” setting you have for this layer as well as “priority”. I am guessing that this is one of the “template” layers, which has max. cloud coverage set to 20%, so that users actually see something interesting for the first time, not just a lot of white clouds.
Alternatively you can add “MAXCC=100&PRIORITY=mostRecent” to the request to ensure, that you really get the last image available.

More info here:
https://www.sentinel-hub.com/develop/documentation/api/custom-url-parameters


#3

Thanks for your quick response,

You can see in my request that I use MAXCC=0.0 as referenced in your documentation https://www.sentinel-hub.com/develop/documentation/api/custom-url-parameters and I have also played with the PRIORITY parameter which is by default set to mostRecent and trying to change the TIME parameter to see what is the gap time between 2 images.

Is there an another parameter that I miss ?


#4

Ah, I missed the MAXCC=0.0, sorry about that. However, this will only give you scenes, which have cloud coverage 0.0. So you have a pretty strict limit… Have you tried with MAXCC=100? This will let all the images through.


#5

No problem :slight_smile: . The value 100.0 is the default and I have also played with this parameter.


#6

I have checked your configuration and this specific layer has priority set to “least cloud coverage”.
If you change this to “most recent” or if you add this parameter to the WMS call and set MAXCC=100, you get more recent data, e.g. 2017-09-23

http://services.sentinel-hub.com/ogc/wms/{token}?REQUEST=GetMap&LAYERS=TRUE_COLOR,DATE&FORMAT=image/png&WIDTH=500&HEIGHT=500&GEOMETRY=POLYGON((-102.6799780643014230%2032.2664152159741064,-102.6798633201786117%2032.2709222209287176,-102.6745585116752011%2032.2708246109079226,-102.6746735175748455%2032.2663176228672697,-102.6799780643014230%2032.2664152159741064))&CRS=CRS:84&MAXCC=100&TIME=2017-09-30&PRIORITY=mostRecent


#7

Oh. Completely miss the point that I can edit my configuration. I understand now why I couldn’t have B1-B12 layers :slight_smile: . It’s working well.

Thank you for your time