Bugs in Source selection?


#1

I am using SentinelHub plugin for QGIS, and my area of interest is Africa.

Last month, default source is Sentinel 2A - L1C, but now it is L2A which the data is not available for Southern Africa.

I am trying to configure back to L1C by selecting the predefined products listed in the dropdown, but this error appeared.

My questions are:

  • Is this a bug, or L1C deprecated?
  • Is it possible to use L2A for countries other than European? If so, when?

Thank you!


#2

Let me first respond to the questions at the end:

  • L1C is not deprecated. It will be supported for the foreseeable future, until it becomes clear that L2A can replace L1C in all means. It is however not expected this to happen shortly (see below).
  • ESA is supposed to start processing L2A globally today (see https://cophub.copernicus.eu/news/News00252). As soon as this happens, the data should become available through Sentinel Hub as well. We do however expect that there will be no L2A processing for the archive data for at least next 6-12 months.

We will check the issue you have reported, it is almost certainly a bug.


#3

After further inquiry we are no longer certain there is a bug :slight_smile:
When creating a new layer, default data source is still Sentinel S2-L1C, as it was. When creating a new layer (or changing a data source), you need to configure “Data processing” method, which you do by clicking the blue pencil right of the warning message.


#4

Thank you very much. It works now.