DEM request error!

Hello everyone! I would appreciate it if you could assist me in obtaining a DEM image when I invoke it in my webGIS using Custom Script Editor. I have already attempted the following code, but unfortunately, it does not produce any results. Can anyone suggest an alternative method or solution?
here’s my script

Best regards

Hi Noureddine,

It is only a screenshot but I think your custom script is fine. It might be to do with the configuration of your layer. In your Dashboard, if you navigate to the layer you can click on Advanced Options:

You can then see the JSON Layer Configuration. I have also created a DEM layer in my dashboard so you should be able to use mine to troubleshoot any issues with your configuration.

If this doesn’t help, please come back to us and we can help you troubleshoot further :slight_smile:

“Dear @william.ray I wanted to express my gratitude for your assistance, as it has successfully resolved my issue. If you don’t mind, I have an additional question. Is there a method available to adjust the resolution of this DEM image to either 15m or 10m?”

Hi Noureddine,

As is described in the documentation, you can adjust the resolution in the WMS request that you will be using in your WebGIS. These parameters are explained in the table below:

WMS parameter Info
WIDTH Returned image width in pixels. Required, unless RESX is used. If WIDTH is used, HEIGHT is also required.
HEIGHT Returned image height in pixels. Required, unless RESY is used. If HEIGHT is used, WIDTH is also required.
RESX Returned horizontal image resolution in UTM units (if m is added, e.g. 10m, in metrical units). (optional instead of WIDTH). If used, RESY is also required.
RESY Returned vertical image resolution in UTM units (if m is added, e.g. 10m, in metrical units). (optional instead of HEIGHT). If used, RESX is also required.

However, there is probably not any discernible benefit in using 10m resolution with the DEMs available through this Data Collection as the most high resolution DEM is only 30m in spatial resolution.

Again, I hope the information helps you out :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.