EOPaches empty Slovenia

Hello Everyone, Please I need Help on Eo patch. I don’t get any result. I created an account Sentinel Hub. I have also created a client and I have my ID and my secret client So I have configured my account. My problem is when I run my code, I get nothing in Eopatch. I have tried to figure out what is the problem and I checked my account configuration but still no result.

Any help please :frowning:
Best Regards

Hi @Maryem

It’s a bit difficult to help you without knowing the steps you have done. Could you please specify the first part of the client ID you are using (don’t write it completely, the first few characters are enough).

In regards to the code, what are you running exactly?

Maxim

Hello,
The OAuth clients’s Id starts with these characters : ‘27224a19’
Now I’m in this step on my code

But eopatches folder still empty.

I see you have run the executor.make_report() function.

This should have created a file called report.html in your working directory which contains the log of your operations along with a status (“Execution successfully finished” or “Execution failed because of an error”) and at the bottom the error message in case of failure. This should put you on the right track to solve your issues.

1 Like

I consult the file report.html and I find this error


Hi @Maryem !

Can you please provide the full report as an attachment?

If possible, the notebook itself might help a lot as well. I am particularly interested how you set up the SentinelHubInputTask.

Regards,
Matic

I try to execute the same example of eoLearn-slovenia Land Cover Classification .

https://eo-learn.readthedocs.io/en/latest/examples/land-cover-map/SI_LULC_pipeline.html

Thanks for the information. Then I would say that the issue is in your credentials either not being set up correctly or not being used by the task correctly.

I would suggest that you follow the example here: Sentinel Hub Process API services from within Python — Sentinel Hub 3.2.1 documentation

and try loading the credentials into python. After that, check the output of config if the credentials are correctly set, otherwise set them from inside of python.

When the config object is correctly set, pass it to the SentinelHubInputTask, like this

band_names = ['B02', 'B03', 'B04', 'B08', 'B11', 'B12']
add_data = SentinelHubInputTask(
    bands_feature=(FeatureType.DATA, 'BANDS'),
    bands = band_names,
    resolution=10,
    maxcc=0.8,
    time_difference=datetime.timedelta(minutes=120),
    data_collection=DataCollection.SENTINEL2_L1C,
    additional_data=[(FeatureType.MASK, 'dataMask', 'IS_DATA'),
                     (FeatureType.MASK, 'CLM'),
                     (FeatureType.DATA, 'CLP')],
    max_threads=5,
    config=config  # <--   this was added
)

Let me know if this helps.

Cheers!

thank you for your feedback .
I checked my credentials ,they are correctly set.
I add this line of code :config=config to the setting of the SentinelHubInputTask.
But I still have the same error

Hi,

I checked my credentials, they are correctly set.

That’s good to hear!

But I still have the same error

That’s not so good to hear.

Unfortunately, I still can’t help much without getting my hands on the full report or on the full notebook. I ran the original notebook and it runs fine for me in its out-of-the-box state, so if it’s possible that you are making slight changes, this could affect the processing.

A couple of more ideas:

  • the code you are using is not updated
  • potential change of location/date

It would be most helpful if you throw everything in a .zip file and share it via dropbox/wetransfer/…

Cheers!

Please find bellow the link of the report file

Hi @Maryem

Thank you for the full report, it’s much more helpful.

When I look at the stack trace, I see the issue of the CLM not being available in the AddValidDataMaskTask, which means it was not downloaded.

When I check the SentinelHubInputTask, I don’t see CLM anywhere in the additional_data.

This is from the report

 bands: ('B01', 'B02', 'B03', 'B04', 'B05', 'B06', 'B07', 'B08', 'B8A', 'B09', 'B10', 'B11', 'B12')
 additional_data = [(<FeatureType.MASK: 'mask'>, 'dataMask', 'IS_DATA')] 

where you download all the bands but only the dataMask (no CLM). However, in the latest docs here: How To: Land-Use-Land-Cover Prediction for Slovenia — eo-learn 0.9.0 documentation

which you provided yourself, you can see that the download is done only for a limited amount of bands, but also for CLM and CLP

# TASK FOR BAND DATA
# add a request for S2 bands
# Here we also do a simple filter of cloudy scenes (on tile level)
# s2cloudless masks and probabilities are requested via additional data
band_names = ['B02', 'B03', 'B04', 'B08', 'B11', 'B12']
add_data = SentinelHubInputTask(
    bands_feature=(FeatureType.DATA, 'BANDS'),
    bands = band_names,
    resolution=10,
    maxcc=0.8,
    time_difference=datetime.timedelta(minutes=120),
    data_collection=DataCollection.SENTINEL2_L1C,
    additional_data=[(FeatureType.MASK, 'dataMask', 'IS_DATA'),
                     (FeatureType.MASK, 'CLM'),
                     (FeatureType.DATA, 'CLP')],
    max_threads=5
)

So there is an inconsistency between your code and the latest code. I would suggest updating the eo-learn code, or removing+re-downloading+reinstalling it, just to be sure.

Hope that helps.

Cheers,
Matic

Thank you very much, it works!
But , in the next step I get this error

Excellent!

Regarding your new issue, I get this as well. We will fix it in the near future, until then, use the following fix:

from dateutil.tz import tzutc
date = datetime.datetime(2019,7,1, tzinfo=tzutc())

That should fix the issue.

Cheers!

Thanks you very much !
It works very well! :smiley: :rose:

I am very sorry, I disturb you a lot but sincerely I try to execute this example well to better understand EOLEARN.
In the next step I get this :


What should I do please !

Hi @Maryem

no worries at all, we are here to help you :slight_smile:

It seems that the issue is with your computer, namely that you don’t have enough RAM space :confused:

One possibility would be to decrease the amount of sampled pixels a few cells above.

in How To: Land-Use-Land-Cover Prediction for Slovenia — eo-learn 0.9.0 documentation

try to decrease the number below

# TASK FOR SPATIAL SAMPLING
# Uniformly sample about pixels from patches
n_samples = 125000 # half of pixels

for example to 75000, or even less if the issue persists.

Regards,
Matic