NDWI data download - wrong values?

Hi, how is it that NDVI values in QGIS show positive (1) values for water bodies even though they are supposed to be lower than 0? It seems the range has just been set up the wrong way round?

Hi @t.griesbaum97,

do you mean NDWI or NDVI? your title says NDWI while in your description you refer to NDVI.

So if you mean NDWI, yes, water will have positive values.


Hi, I meant NDVI, sorry! but for NDWI it’s actually the same issue: downloaded NDVI and NDWI GeoTiff data both show wrong values in QGis for water, vegetation, sand etc…
In GIS, adding the NDWI, water bodies show values of <0.5 instead of >0.5.

Only if I create NDVI by myself ((B8-B4)/(B8+B4)) the values correspond to the original categories (f.ex. NDVI: values lower than 1 = water, -0.1-0.1=Sand…0.2-0.4 =grass, shrub, etc…) as presented by EO Browser.


  • If you are downloading the NDVI GeoTiff from EO Browser, those are not actual values. they are visualized values.

  • You already said that you created it yourself, but in case you didn’t know, If you want to download NDVI Geotiff with actual values that follow your trend, you can use process API request. See the example in the documentation.

  • Also, in my opinion, NDWI values for water bodies isn’t necessarily > 0.5, I think it could also range from 0.3, 0.4 depending on the water body and the image itself.

I hope that helps
Happy holidays

Thank you! Yes, this helps a lot! The only thing I am wondering about is which band combination I am using for the NDVI extraction in QGis (Raster Calculator) → ((B8-B4)/(B8+B4)) with band 1 or 2. For now it seems right to use band 1 for both B8 and B4 without considering band 2 of B4 and B8 - am I right? / See picture “B04_(Raw)@1” … “@2” etc.

Thanks and Merry Christmas! :slight_smile:

Hey @t.griesbaum97 ,

it’s correct using band 1 for calculations (NDVI or any other calculation). Band1 in the raw band data contains the data values, band2 contains a data mask for this raw band.

If you don’t need the dataMask there is an option to exclude it when downloading the raw band (only if tiff is selected). Simply disable Add dataMask band to raw layers in the options and you will only get 1 band in each tiff.


I am facing a similar problem. After uploading the band images in QGIS, the NDWI of images from Landsat 8-9 in particular are wildly off the range even though I am applying the standard formula in the raster calculator.
Faced similar results while calculating in Rstudio as well.
Any idea why?