Resolution and cropping issue for Pleaides

Hi - I have never downloaded Pleiades data from here before, but ordered two scenes (just under 20km2 total). I downloaded them as ‘high’ resolution (analytical), assuming that would be the native 0.5m resolution of Pleiades, including both true colour and true colour pan sharpened. Both scenes have different resolutions, of about 1 and 3m. Further, one of the scenes is not cropped as I had set in EO-Browser. See attached (EDIT - as a new user I can only embed one image…will post a response if i can with the others). Two images from EO-Browser show the AOI I set and the Pleiades scene in background. The third image is in QGIS and shows much of the western part of the scene is not there. Any suggestions? Thanks in advance.

Here is EO-Browser scene #2

And finally, here is the scene as downloaded and loaded in QGIS

strong text

First for the resolution. Pleaides data comes with 2m multi-spectral band and 0.5m panchromatic band.
In the screenshot you attached it is clear you have not selected “pansharpened” option, which means you get “raw” 2-meter resolution MSI bands. If you switch to “True Color Pansharpened”, you will get 0.5m image. As an example, your image in QGIS, clearly having 0.5m pixels.

I do not understand your second comment. If I compare “Order geometry” (which you can download from Dashboard → 3rd party data → Order → Geometry → Save as GeoJSON), I see they match.

This area also matches 5.68 km2, the quota consumed.

Thanks for the rapid response. In the first image, I was just playing around with those band combos and so maybe didn’t screen grab the appropriate one, but I definitely selected the pan-sharpened in the ‘download’ popup. I just tried again but selecting first the pan-sharpened option on left as you suggest, and then also on download popup and it seemed to download the appropriate footprint. I have no idea why it didn’t the first time. But it’s still showing as 2m resolution or so (2.3, actually…see screen grab). When you tried exporting it, how many pixels was it? I see ‘High’ as 2500x1197.

Ah, now I understand.
In EO Browser, you can export the GeoTiff up to 2500x2500 px. If you want to export whole image, you can use sh-py package for large areas. Alternatively, zoom in and export that area with full resolution.

There is also “hi-res image export” in EO Browser, but that one comes without georeference, so you cannot use it in QGIS.

That said, if you want to use the image in QGIS, simple use WMS or our Plugin:

Thanks - I will try the sh-py package but I still don’t understand how to export the area with full resolution. That’s what I’m trying to do, but it does not seem to be working. Is there a tutorial you can point me to?

You will find example in the documentation:

Is there really no easy button I can pretty to download the full-resolution scene? I feel like I’m missing something obvious here!

You cannot download the whole scene with an easy button. You can do this in several steps in EO Browser or use Python package to do that for you.