Sentinel-2 L2A inconsistencies

Dear community,

I have recently faced issues due to what I believe to be inconsistencies in Sentinel-2 L2A products.
I am interested in monitoring vegetation in Thailand, especially the harvest season between January and March, which naturally leads me to use the NDVI.
However, my time series are severely impacted by the processing of the images, leading to early and erroneous harvest detection because of gaps in time series.
The image is at longitude is 101.03302, latitude is 13.5416, in the Bangkok area.

I have listed five cases that I compiled in the image attached to this post:

  1. Clear image, no issue
  2. Cirrus in the scene, apparently well detected on the SCL and corrected in the L2A which seems correct yet a little pale
  3. A discrepancy of contrast between parts of the L2A (upper part is more white than the bottom part), and an undetected fire smoke on the bottom left
  4. A very pale L1C rgb image, even though no cirrus appearing on B10 and the SCL is normal
  5. Clear L1C, no cirrus, normal SCL, but hazy L2A and undetected thin “clouds” (I don’t know if it’s smoke, fog, clouds or anything else)

I am trying to understand where these discrepancies originate from, if this is expected in the products, and how to deal with it, as my resulting NDVI timeseries are quite impacted by those issues.
I suspect this is an issue with sen2cor as it happens that at the same date, a tile can be correctly processed but its immediate neighbor can be very hazy/whitish, with artifacts on the landforms.
It also happens that on some defective images, the vegetation in the SCL is not detected as such at all but is classified as “not vegetated” instead.
Is there an explanation on this phenomenon?

As a side question, I also wanted to know if the haze removal that is mentioned in the L2A processing documentation is sometimes/automatically/never applied.

I hope this is the correct place to report and interrogate such issues ? I have been unsuccessful in receiving an answer on the Copernicus forum.

Thank you in advance for your help, I hope I provided enough details, in case feel free to ask for more.

Here is a second scene with the neighboring tile inconsistency problem, at longitude 100.93500, and latitude 14.46776. The landform artifacts are quite visible in the bottom right corner.

Sentinel Hub provides access to EO images, but is not responsible for the data itself. I would recommend to submit a request here: https://helpcenter.dataspace.copernicus.eu/hc/en-gb/requests/new