Sentinel-2 No Data retrieved in smaller extents (WMS service)

There seems to be a problem with some of the images of Sentinel-2, in the WMS layer of Moisture [MOISTURE_INDEX]. We detected this problem for the 05 and 10 of March 2022, but there is also some examples in 2021.
For the area of southern Portugal, images are retrived if the request includes big extents (example 1). If we request a smaller extent (BBOX), within the area of the previous request, no image is returned (examples 2).
Can you help us to find what is happening?

Thank you

Returns data, big extent (5 of march)
Example 1:[OUR_ID]?SERVICE=WMS&REQUEST=GetMap&FORMAT=image/png&TRANSPARENT=TRUE&STYLES=&VERSION=1.3.0&LAYERS=MOISTURE_INDEX&WIDTH=1176&HEIGHT=714&CRS=EPSG:3857&BBOX=-1035890.3069236815,4671564.760585265,-676330.5258703852,4889868.913367623&TIME=2022-03-05%2F2022-03-05&SHOWLOGO=FALSE

Does not return data, small extent (5 of march)
Example 2:[OUR_ID]?SERVICE=WMS&REQUEST=GetMap&FORMAT=image/png&TRANSPARENT=TRUE&STYLES=&VERSION=1.3.0&LAYERS=MOISTURE_INDEX&WIDTH=1176&HEIGHT=714&CRS=EPSG:3857&BBOX=-858648.1220038037,4773921.583295768,-813703.1493721807,4801209.60239354&TIME=2022-03-05%2F2022-03-05&SHOWLOGO=FALSE

Thanks for raising this Rui. Indeed, I get the same error as you. We’re looking into the error and will update once fixed.

Hi Rui,

By default, the maximum cloud cover (MAXCC) parameter is set to 20% so these tiles are filtered out. For your request that worked, the resolution is coarse enough that preview mode: where the maxCloudCoverage filter is not applied.

However, your second request was at a much higher resolution, so the cloud cover was accounted for. As the scene cloud cover percentage exceeded 20% no data pixels were returned.

To solve this, you can add MAXCC=100 into your WMS request. This sets the maximum image cloud coverage to 100%, so no matter what cloud cover percentage the image has the pixels are returned. This would look like this for your smaller AOI:[OUR_ID]?REQUEST=GetMap&CRS=EPSG:3857&BBOX=-858648.1220038037,4773921.583295768,-813703.1493721807,4801209.60239354&LAYERS=MOISTURE-INDEX&WIDTH=1176&HEIGHT=713&FORMAT=image/png&TIME=2022-03-05/2022-03-05&MAXCC=100

You can experiment with additional parameters here.

Alternatively, you can change the “cloud coverage” parameter in the Configuration utility/