"Show data" button is not displayed after purchasing commercial data


I want to display the commercial imagery I bought on the EO Browser. I ordered Maxar’s imagery and it finished. But “Show data” button is not displayed on the Finished orders. There are only two button; delete and show coverage. Is there any solution? I just want to download true colour image.

1 Like

+1, The same question for Planet Scope tiles and subscriptions. Only one of three tiles appears to have such button

1 Like

@Andrei_A I am in the same situation. I bought another imagery of Maxar and I could have display it using “Show data” button. Only one of the two images displays the important button. So I used API, requests-builder, to get the true colour image instead of the button.

1 Like

For the “Show data” button to appear, the following conditions need to be met:

  • order is DONE
  • there exists a Configuration, which has layers configured with the Collection, where this order was delivered to (this is needed to actually know how to visualise the data).

The reason, why you don’t see it, is probably due to not selecting default (i.e. “My Maxar Data”) collection, but either some other one, or “Create new collection”. To solve the issue, you need to make a relevant Configuration for that specific collection (go to Configuration utilty, Create new configuration based on the template, then copy-paste collection ID).

Note that you can also download the original data by going to 3rd Party Data tab in the Dashboard, finding the specific order, then using the “Download TPDI original data” button in the Deliveries section.

I hope this helps.

1 Like

@gmilcinski Thank you for your help. I finally could have displayed the button and the true colour imagery on the EO Browser. I understand I did some wrong settings about the collection when I ordered my first image.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.