Statistical info API + Landsat 8 = Oops!


#1

Hi all,

I tried to use Statistical info API on Landsat 8 satellite.
This satellite do not use the same endpoint (services-uswest2.sentinel-hub instead of services.sentinel-hub). So I adapted my URL.

But now, when I try to request, I have a 503 error (Oops!, Something went wrong.).

Here is the URL I use : https://services-uswest2.sentinel-hub.com/fis/MYPERSONNALID?LAYER=NDVI&STYLE=INDEX&CRS=EPSG:4326&RESOLUTION=10m&TIME=2000-01-01/2018-12-31&BBOX=-54.8625106271707,-68.6261626271707,-54.8544093728293,-68.6180613728293&MAXCC=50

Did I do something wrong ?

Thank you for your help


Download NDVI graph values
Statistical info API - Questions regarding history
#2

There are three problems here:

  • you forgot to include /ogc/ in the URL - it should be https://services-uswest2.sentinel-hub.com/ogc/fis/
  • you are trying to get NDVI on “visualized” layer, which will not work. Instead, you will get values of R, G and B of the NDVI visualization, which does not make much sense. To get actual NDVI values, you need to configure the layer to retrieve these. Check this FAQ (and adapt for Landsat band values)
    https://www.sentinel-hub.com/faq/how-do-i-get-actual-ndvi-values
    (The fact, that the request works on Sentinel-2 is due to backward compatibility. In old times we had several “styles” for each layer, which did not work well. So we changed this about a year ago.)
  • There is no “STYLE” parameter for Landsat, in line with the bullet above. This does not cause problems, but does not do any good either.

I have created a new layer on your instance, called NDVI-VALUE. Try this:

https://services-uswest2.sentinel-hub.com/ogc/fis/<INSTANCE_ID>?LAYER=NDVI-VALUE&CRS=EPSG:4326&RESOLUTION=10m&TIME=2000-01-01/2018-12-31&BBOX=-54.8625106271707,-68.6261626271707,-54.8544093728293,-68.6180613728293&MAXCC=50


#3

Great !!

Thank you very much for your answer and your reactivity.

And thank you for creating a NDVI-VALUE. But, I should use it in my request instead of the NDVI layer you put in your example no ?


#4

You are right, thanks! I have edited my post.