Visualizing Pleiades data in EO Browser after order

Hello, I got 5 km² of Pleiades quota from you that I was able to order through https://apps.sentinel-hub.com/requests-builder

All worked as I would expect. Then I went into the dashboard, set up the configuration and added the collection ID to it. After that I went into EO Browser, selected the correct theme and date. The Pleiades image showed up in the results in Discover and when I clicked on Visualize a ‘wheel’ started turning as if indicating that the image was being loaded. It didn’t, however. No matter how long you wait, it doesn’t seem to load. I’m not sure what is happening in the background, if there was any error or not. No error message ever shows up at least.
image

Any idea what could be causing this? In the configuration I’m able to see a preview of the image.

Thank you in advance.

Dear @redsky,

to help us to investigate your problem it would be great if you could share with us a screenshot of the console log. You get to the console by pressing F12. Most probably there will be some additional info what is going wrong in the background.

Best,
Daniel

Hi Daniel,
Thank you for your reply. The console seems to have some information for us. When I click on the visualize button I get a 404 error. It seems like instead of the collection ID it is sending 00000000-0000-0000-0000-000000000000 as a request, this is what I get:

{"error":{"status":401,"reason":"Unauthorized","message":"You are not authorized - please provide header [Authorization: Bearer <accessToken>] with your request.","code":"COMMON_UNAUTHORIZED"}}

I can replace it with my collection ID. If I do that I get the following response:
{"@id":"https://services.sentinel-hub.com/configuration/api/v1/metadata/collection/CUSTOM/**COLLECTIONID**","id":"**COLLECTIONID**","location":{"@id":"https://services.sentinel-hub.com/configuration/api/v1/metadata/location/aws-eu-central-1","id":"aws-eu-central-1","url":"https://services.sentinel-hub.com","wmsUrl":"https://services.sentinel-hub.com/ogc/wms","processUrl":"https://services.sentinel-hub.com/api/v1/process","catalogUrl":"https://services.sentinel-hub.com/api/v1/catalog"},"datasetType":"CUSTOM","bands":[{"name":"B0","sampleType":"UINT16"},{"name":"B1","sampleType":"UINT16"},{"name":"B2","sampleType":"UINT16"},{"name":"B3","sampleType":"UINT16"},{"name":"PAN","sampleType":"UINT16"}]}

Note: I replaced my collection ID with COLLECTIONID. If you need it let me know.

I’m not sure why it uses 00000000-0000-0000-0000-000000000000 instead of my collection ID, in the request preceding this one it did use my collection ID and as you might expect I got a 200 response back. It might be something in the collection’s settings that isn’t properly set up, but I wouldn’t know what.

Update, I don’t know what happened but all of a sudden I see it loaded in EO-Browser. I really don’t know what happened, if I did something, or if something happened in the backend. :smiley:

Hi @redsky,

thanks for the info from the console and great to hear that it’s working for you now! :slight_smile:

Can it be that you created a new instance from our templates and forgot to update the collection id there? (The default is the “only zeros” you described). See therefor also our latest webinar.

Otherwise there are really rarely issues with the authentication. A (hard) refresh of the page often solves the problem (if your session expired you will get asked to login again).